Emulation General


205pages on
this wiki

Xebra is a PlayStation emulator. It focuses on accuracy and only outputs in native resolution.

It is one of the only PS1 emulators to include compatibility with PocketStation.


Scroll down to the bottom of the official website and click on the first picture, the 2nd one is for the Android version.


XEBRA is an emulator that is reverse engineered from PS1 hardware by a Japanese programmer (Dr.Hell) resulting in the absolute most accurate PS1 emulator to date, similar to what is Higan (BSNES) for Snes.

As current development of XEBRA is focused on accuracy, the GUI is not user friendly like other emulators and every function has to be done by selecting from a drop down menu of non intuitive commands directly translated from Japanese.

Problems and solutionsEdit

As of Oct 11th 2015 build, Xebra uses WaveOut as sound output. The audio will remain in perfect sync with the emulation and all crackling, buffering settings issues, stutter loops (when menu is selected) are no longer present.

Using XebraEdit

the XEBRA distribution comes with several executable those are:

  • XEBRA.EXE: the emulator itself
  • MCM.EXE: a memory card manager that allows you to edit memory card image files directly.
  • SIM.EXE: a editor for xebra emulation fine tuning options, that allows you to save setting as a single file for ease of having a configuration for specific games, mostly for advanced users as most games runs fine now.
  • older versions of Xebra used to come with Arbex.exe which was a version of Xebra that did not needed bios, however as of the 20th june 2015 version, Xebra does not need bios anymore.

The Xebra Interface essentially imitates the way the real psx works, for example choosing a iso or a game cd is the same as placing the physical disc it on drive the original psx. most options such open/close shell, power, reset, start/stop card, loading memorycard image and so work pretty much as they would if you did it on a real console. most of the other options are for debugging or advanced tuning of the emulator.

Setting the bios Edit

The Newer Version of Xebra comes with its own bios replacement, however if you having problems with a game you can still set the bios by doing the following:

File -> Open -> OSROM image. That will copy the bios file to the xebra directory and renaming it to OSROM (with no file extension). Doing that manually works as well.

Loading Games Edit

File->Open-> "CD-ROM via SPTI..." for a real CD in your cdrom drive or Daemon Tools emulated drive and select any file on the root of the CD.

File->Open-> "CD-ROM Image..." for an Image file (iso,cue, etc...) that has the same effect as the former but may have problems with CD-Audio and multi track CDs or simply not load at all.

To play you need to use "Run->Power(Run)" or F5, XEBRA supports several image formats when in doubt between a which file to load (cue/bin/mdf/ccd/img/etc) choose the largest one and XEBRA will automatically look for file it needs as long it has they share the file name (game.ccd and game.img for example).

Note: Use latest Demon Tools Lite to load images instead of opening images directly in Xebra for best and most accurate emulation. XEBRA was created to be used with a CD drive and nothing does CD drive emulation better than Daemon Tools. The internal Xebra image loader sometimes has problems with CD-Audio and multi track CDs or not load at all.

Changing discs Edit

In games that need to change discs, you essentially do the same that you would do on a real psx.

  1. open the psx cd drive with Run->Open Shell.
  2. change the current disc on the drive with File->Open->CD-ROM via SPTI... or CD-ROM Image and select a file on the root of the CD.
  3. close the cd drive with Run->Close Shell.

Setting up controls Edit

That's the most complicated part of using Xebra, first choose "View->Controllers..." that will open a popup window with the current settings. The top drop down menu allows you to choose between changing the configurations of controller 1 or 2. The drop down menu below that will let you choose the kind of controller is connected in that controller port:

  • No Controller: as it says, it acts like nothing is connected in that port
  • Mouse: psx mouse
  • Digital Controller: The launch PSX controller without analogs sticks (original PS1 Controller)
  • Analog Controller: An upgraded PSX controller with dual analog sticks, (original PS1 Dual Analog Controller)
  • Virtual Dualshock: The Dual Analog successor, Dualshock controller (original PS1 Dualshock Controller).

As with the original Dualshock, if a game does not respond to the Dualshock just click the "analog" button between the analog stick to turn the Dualshock to a Digital controller. If this button is not assigned in the Controller menu just press F11 on the keyboard.

The buttons in the windows are the buttons in the controller, they are laid out almost in the same way the buttons in the real psx controller are(having the window open without controller port selected will show which each button is), press any of those followed by the button you want to use for it to set it up (note that there is also a set up for the ANALOG button) the 4 drop down menus and the fields below it are for the analog sticks first is the X and Y axis for the left analog then the X and Y axis for the right analog, the numbers below it are the dead zone and the max range for the said axis.

It share the button configs across different controllers types, so you can change between analog and digital controllers without having to set up the buttons again. (NOTE: many psx games do not recognize the Dual Shock and will not work unless set up with digital controllers or press F11 when the game complains).

Audio and Video settingsEdit

As XEBRA aims to be a accurate emulator and does everything in software so there is not much to change

View->Video Output... Edit

will take you to video settings which are:

  • Use OpenGL: uses openGL to stretch and present the video output, unless this is set up it will scale with software which is very slow, so just keep it on unless you have issues.
  • Draw with Opengl(experimental): render the game with openGL in Hi Resolution like other emulator, it doesn't work very well for now. If you wish authentic PSX experience keep it off.
  • Stretch with GDI: Lets windows Graphic Device Interface stretch the image to the window size. Now works with OpenGL and should be kept On.
  • Whole Frame Buffer: it will output the whole frame buffer, which usually is just a garbled mess, for debugging purposes. Keep off.
  • Nearest: only if Stretch with OpenGL is chosen, it will stretch using "nearest pixel" filter, this will keep all the pixels in their pixelated glory, else it will use billiear filtering which blurs the whole thing. Original PS did not use filtering at all.
  • Progressive: the original psx video output like most analog TVs was interlaced, this will double the lines to output a progressive image. if you leave this off you can get line artifacts with fast motion(think psp 3000). No real reason to keep it off
  • Drawing skip: this is a frame skip setting, 0 means no frame skip and any other number means skipping N frames for every frame draw. Something to try if your computer can't handle Xebra.
  • Display Skip: a different kind of frame skip, it will run internally just as normal but will only show a frame every N frames, 0 means no skip. Note: for some strange reason Xebra comes with a value 2on this by default which does cause massive stuttering in 2d games. you might want to change that to 0.

View->Audio Output... and View->CD-ROM Drive... Edit

those are mostly emulation fine tuning settings, which are really complicated, don't touch it unless you know what you are doing.

View->Debug Edit

is a debug utility which even i never figured how it works. you will never need to use this.

View->Width Edit

this allows you to change the width of the window.  

View->Height Edit

the same but for Height, however the options in the format "number:number" are special as they set the Height based on the current Width to reach that aspect ratio. use 16:12 for a normal SD aspect ratio(4:3) and 16:09 or 16:10 for widescreen aspect ratio  

View->Rotate Edit

rotates the output in a 90 degree angle, some shmups can be set up in game to output image like that.

View->Scale Edit

essentially it's for the screen streching and blackbars so it will fit on 16:9 and 16:10 resolution without distorting the image, 16:12(4:3) is the default option and the ones that does nothing, pretty much what you want to use for windowed modes (changing the window size to a 4:3 resolution is easier and better than messing with this). else is a matter of trying till find one you like, however some of the options doesn't seems to work at all.

View->Full Screen Edit

puts XEBRA on full screen mode on said resolution, note that pressing F12 in windowed mode will also take it to full screen and ESC will being it back to windowed, pressing F12 on full screen mode will also show the menus.

Dealing with memory cardsEdit

as default Xebra will start with two memory cards plugged into it, those are stored as the files "BU00" and "BU01" in the xebra directory. those memory cards works just as you would expect a real memory card to work, you can even manage them in the memory card screen of the psx itself. (open shell and reset the console).

to load a diferent memory card go to File->Open->Memory card 1/2 Image...  you can also save a copy of the current memory card with File->Save->Memory card 1/2 Image... that has the same effect as changing memory cards in a real psx, so don't do that while saving.

to remove all memory cards and act like there is none plugged to the console choose "Run->Stop card" and "Run->Start card" to plug them back.

the program MCM.exe however allows you to manage memory cards image files directly and in a more practical way:

  • the option View->Remove SJIS will try to show the file names in non-japanese characters which is a lot more useful for us.
  • it will show some things differently from the psx manager including only the first of a multiblock save having a file name while the others will be just named "LINK", only the first file can be edited however.
  • double click in a file then a pop up with appear, press yes to delete and no to save that file as a single file.
  • the open files menu only look for files with the extension .mc... even tough the default memory cards image files have no extension, just set it to open "all file types" for those
  • it can save the images in different formats and even just save the icons as bmps, However use the save->general to save in a Xebra format.
  • you can always edit a memory card image while the emulator is running in case you run out of space.

Emulating PocketStationEdit

Pocketstation in use

1) Download both Xebra and PK201.
2) Put everything in a folder together with respective FROM, KROM and OSROM files.
3) Run PK201 and do the initial setup, select File -> Save STAT and close it.
4) Run Xebra, select whatever game you like, then select Run -> Run-1/2/3 to start the game.
5) When in game, select Run -> Outer Card to start PocketStation emulation.
6) Enjoy your Chocobo Worlds or whatever.

Around Wikia's network

Random Wiki